Battle Pirates Players Forum

Game Issues => In Game Issues => Topic started by: . Jw-Drowning C.M. on July 30, 2012, 03:40:58 pm

Title: In Game Issues
Post by: . Jw-Drowning C.M. on July 30, 2012, 03:40:58 pm
Use the section to talk about in game issues, bug glitches ect. that need to be addressed in game.
Title: Re: In Game Issues
Post by: Lords_of_Battle on July 30, 2012, 04:00:59 pm
I have a problem. I had a 48 hour clock. When I logged on again it rolled down to 2 hours. What do I do?
Title: Re: In Game Issues
Post by: . Jw-Drowning C.M. on July 30, 2012, 04:15:53 pm
I have a problem. I had a 48 hour clock. When I logged on again it rolled down to 2 hours. What do I do?

Not sure I understand your question.
Title: Re: In Game Issues
Post by: defeter23 on July 30, 2012, 04:36:29 pm
The fleet hopping thing when you come out of an attack.
Title: Re: In Game Issues
Post by: ark on July 30, 2012, 04:39:23 pm
The fleet hopping thing when you come out of an attack.

yea i hate this one you have to attack a base and leave 30 seconds earlier so you can jump back to the base your hittin.
Title: Re: In Game Issues
Post by: defeter23 on July 30, 2012, 05:55:09 pm
Also the insta base repair thing.
Title: Re: In Game Issues
Post by: FaTTy on July 30, 2012, 11:54:40 pm
That gets to be rather annoying
Title: Re: In Game Issues
Post by: Kercookie-Drowning on August 30, 2012, 02:37:26 pm
Anyone havong a problem with not being able to see your ships? I reported the problem to Kixeye and of course the problem according to them lies in the fact that I dont run google chrome even thou I never have and have been playing for a long time...Kixeye get's on my nerves so bad, always when we have a raid there is a problem!
Title: Re: In Game Issues
Post by: The Darker Side on September 25, 2012, 06:46:56 pm
i run Chrome and i have the same problem